Укажите, как нужно доработать программу, чтобы не было случаев ее
Условие

Требовалось написать программу, при выполнении которой с клавиатуры считываются координаты точки на плоскости (x, y - действительные числа) и определяется принадлежность этой точки заданной закрашенной области (включая границы). Программист торопился и написал программу неправильно.Паскаль | Бейсик | var x,y: real;beginreadln(x,y);if y<=x+1 thenif y>=xx-1 thenwrite('принадлежит')elsewrite('не принадлежит')end. | INPUT x, y IF y<=x+1 THEN IF y>=xx-1 THEN PRINT "принадлежит" ELSE PRINT "не принадлежит" ENDIF ENDIF END | Си++ | Алгоритмический язык | #include <iostream>using namespace std;int main(){float x,у;cin >> x >> y;if (y<=x+1)if (y>=xx-1)cout << "принадлежит";elsecout << "не принадлежит";} | алгначвещ х,уввод х,уесли y<=x+1 тоесли y>=xx-1 товывод 'принадлежит'иначевывод 'не принадлежит'всевсекон | Python | x = float(input())y = float(input())if y<=x+1: if y>=x*x-1: print("принадлежит") else: print("не принадлежит") | Последовательно выполните следующее.

- Заполните таблицу, которая показывает, как работает программа при аргументах, принадлежащих различным областям (A, B, C, D, E, F, G и H). Точки, лежащие на границах областей, отдельно не рассматривать.В столбцах условий укажите "да", если условие выполнится, "нет" если условие не выполнится, "—" (прочерк), если условие не будет проверяться, «не изв.», если программа ведет себя по-разному для разных значений, принадлежащих данной области. В столбце "Программа выведет" укажите, что программа выведет на экран. Если программа ничего не выводит, напишите "—" (прочерк). Если для разных значений, принадлежащих области, будут выведены разные тексты, напишите «не изв». В последнем столбце укажите "да" или "нет".2. Укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы. Область | Условие 1 (y<=x+1) | Условие 2 (y>=xx-1) | Программа выведет | Область обрабатывается верно | A | | | | | В | | | | | С | | | | | D | | | | | Е | | | | | F | | | | | G | | | | | Н | | | | | Критерии оценивания выполнения задания | Баллы | Обратите внимание! В задаче требовалось выполнить три действия: указать для каждой области, как будет работать программа, что она выведет на экран и правильно ли это (в виде таблицы), и исправить две ошибки. Баллы за данное задание начисляются как сумма баллов за верное выполнение каждого действия. 1. Верное заполнение предложенной таблицы. 2. Неправильное использование условного оператора, в результате чего при невыполнении первого условия программа не выдавала ничего (отсутствует ветвь ELSE). Исправлением этой ошибки может быть либо добавление ветви ELSE к каждому условию IF, либо объединение всех условий IF в одно при помощи конъюнкции. В сложных случаях это действие считается выполненным, если программа выдает одно из двух сообщений «принадлежит» или «не принадлежит» для любых пар (x,y), при этом программа не стала работать хуже, чем раньше, то есть для всех точек, для которых программа ранее выдавала верный ответ, доработанная программа также должна выдавать верный ответ. 3. Приведенных трех ограничений не достаточно для описания двух областей (потеряно условие xx + y*y <= 16). Исправлением этой ошибки может быть использование одного условия с логическими операциями конъюнкции и дизъюнкции, либо использование вложенных условий с ветвями ELSE. В сложных случаях это действие считается выполненным, если верно определены закрашенные области, то есть программа выводит сообщение «принадлежит» для всех точек закрашенных областей и только для них, для точек вне закрашенных областей программа выводит «не принадлежит» или не выводит ничего. В работе (во фрагментах программ) допускается наличие отдельных синтаксических ошибок, не искажающих замысла автора решения. Правильно выполнены оба пункта задания. Исправлены две ошибки. Программа для всех пар (x,y) верно определяет принадлежность точки заштрихованной области. Допускается наличие ошибок в одной из строк таблицы. | 3 |
- Правильно выполнены два действия из трех (исправлены обе ошибки, но в первом пункте задания не приведена таблица (либо таблица содержит ошибки в двух и более строках), либо приведена таблица (которая содержит ошибки не более чем в одной строке), но исправлена только одна ошибка программы). При написании операций сравнения допускается одно неправильное использование строгих/нестрогих неравенств (считается несущественной ошибкой, погрешностью записи). Например, вместо «xx + yy <= 16» используется «xx+yy<16». 2. Или выполнены все три действия, но при этом в логическом выражении неверно учтены приоритеты логических операций (не расставлены или неправильно расставлены скобки в выражениях. | 2 | Правильно выполнено только одно действие из трех, то есть, либо только приведена таблица, которая содержит ошибки в не более чем одной строке, либо таблица не приведена (или приведена и содержит ошибки более чем в одной строке), но исправлена одна ошибка программы. При оценивании этого задания на 1 балл допускается не учитывать корректность работы программ на точках границ областей (вместо нестрогих неравенств в решении были использованы строгие неравенства или наоборот). | 1 | Все пункты задания выполнены неверно (таблица анализа правильности алгоритма не приведена, либо содержит ошибки в двух и более строках, программа не приведена, либо ни одна из двух ошибок не исправлена). | 0 | Максимальный балл | 3 |
Формат задания
Решение по шагам
Как рассуждать
Решение. [рисунок]
Осталось ещё 1 шаг
Полный разбор с проверкой ответа
Бесплатно · займёт минуту