Присоединиться

11 класс·высокий уровень

Укажите, как нужно доработать программу, чтобы не было случаев ее

Условие

| Требовалось написать программу, при выполнении которой с клавиатуры считываются координаты точки на плоскости (x, y - действительные числа) и определяется принадлежность этой точки заданной закрашенным областям (включая границы). Программист торопился и написал программу неправильно.

Рисунок к задаче

ПаскальБейсик
var x,y: real;beginreadln(x,y);if y>=0 thenif y>=2-x thenif y<=x*x thenwrite('принадлежит')elsewrite('не принадлежит')end.INPUT x, y IF y>=0 THEN IF y>=2-x THEN IF y<=x*x THEN PRINT "принадлежит" ELSE PRINT "не принадлежит" ENDIF ENDIF ENDIF END
Си++Алгоритмический язык
int main(void){float x,y;cin >> x >> y;if (y>=0)if (y>=2-x)if (y<=x*x)cout << "принадлежит";elsecout << "не принадлежит";}алгначвещ x,yввод x,yесли y>=0 тоесли y>=2-x тоесли y<=x*x товывод 'принадлежит'иначевывод 'не принадлежит'всевсевсекон
Python
x = float(input())y = float(input())if y>=0: if y>=2-x: if y<=x*x: print("принадлежит") else: print("не принадлежит")

Рисунок к задаче

Последовательно выполните следующее.1. Перерисуйте и заполните таблицу, которая показывает, как работает программа при аргументах, принадлежащих различным областям (A, B, C, D, E, F,G и H). Точки, лежащие на границах областей, отдельно не рассматривать.В столбцах условий укажите "да", если условие выполнится, "нет" если условие не выполнится, "—" (прочерк), если условие не будет проверяться, «не изв.», если программа ведет себя по-разному для разных значений, принадлежащих данной области. В столбце "Программа выведет" укажите, что программа выведет на экран. Если программа ничего не выводит, напишите "—" (прочерк). Если для разных значений, принадлежащих области, будут выведены разные тексты, напишите «не изв». В последнем столбце укажите "да" или "нет".2. Укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы. (Это можно сделать несколькими способами, достаточно указать любой способ доработки исходной программы.) Область | Условие 1 (y>=0) | Условие 2 (y>=2-x) | Условие 3 (y<=x*x) | Программа выведет | Область обрабатывается верно | | A | | | | | | | В | | | | | | | С | | | | | | | D | | | | | | | Е | | | | | | | F | | | | | | | G | | | | | | | Н | | | | | |

Формат задания

Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Разбор откроется после входа.

Решение по шагам

  1. Как рассуждать

    ОбластьУсловие 1 (y>=0)Условие 2 (y>=2-x)Условие 3 (y<=x*x)Программа выведетОбласть обрабатывается верно
    Aданет--нет
    Вдададапринадлежитда
    Сданет--нет
    Dданет--нет
    Едаданетне принадлежитда
    Fдададапринадлежитнет
    Gнет---нет
    Ннет---нет

Осталось ещё 1 шаг

  1. Возможная доработка (Паскаль):if (x<0) and…

Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Исправление ошибок в программе»

Укажите, как нужно доработать программу, чтобы не было случаев ее — решение с объяснением | Lom Ai