Укажите, как нужно доработать программу, чтобы не было случаев ее
Условие
| Требовалось написать программу, при выполнении которой с клавиатуры считываются координаты точки на плоскости (x, y - действительные числа) и определяется принадлежность этой точки заданной закрашенной области (включая границы). Программист торопился и написал программу неправильно.

| Паскаль | Бейсик | ||||
|---|---|---|---|---|---|
| var x,y: real;beginreadln(x,y);if y>=x thenif y>=0 thenif y<=2-x*x thenwrite('принадлежит')elsewrite('не принадлежит')end. | INPUT x, y IF y>=x THEN IF y>=0 THEN IF y<=2-x*x THEN PRINT "принадлежит" ELSE PRINT "не принадлежит" ENDIF ENDIF ENDIF END | ||||
| Си++ | Алгоритмический язык | ||||
| int main(void){float x,y;cin >> x >> y;if (y>=x)if (y>=0)if (y<=2-x*x)cout << "принадлежит";elsecout << "не принадлежит";} | алгначвещ x,yввод x,yесли y>=x тоесли y>=0 тоесли y<=2-x*x товывод 'принадлежит'иначевывод 'не принадлежит'всевсевсекон | ||||
| Python | |||||
| x = float(input())y = float(input())if y>=x: if y>=0: if y<=2-x*x: print("принадлежит") else: print("не принадлежит") | |||||

Последовательно выполните следующее. 1. Перерисуйте и заполните таблицу, которая показывает, как работает программа при аргументах, принадлежащих различным областям (A, B, C, D, E, F, G и H). Точки, лежащие на границах областей, отдельно не рассматривать. В столбцах условий укажите "да", если условие выполнится, "нет", если условие не выполнится, "—" (прочерк), если условие не будет проверяться, "не изв.", если программа ведет себя по-разному для разных значений, принадлежащих данной области. В столбце "Программа выведет" укажите, что программа выведет на экран. Если программа ничего не выводит, напишите "—" (прочерк). Если для разных значений, принадлежащих области, будут выведены разные тексты, напишите "не изв". В последнем столбце укажите "да" или "нет". 2. Укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы. (Это можно сделать несколькими способами, достаточно указать любой способ доработки исходной программы.) Область | Условие 1 (y>=x) | Условие 2 (y>=0) | Условие 3 (y<=2-x*x) | Программа выведет | Область обрабатывается верно | | A | | | | | | | В | | | | | | | С | | | | | | | D | | | | | | | Е | | | | | | | F | | | | | | | G | | | | | | | Н | | | | | |
Формат задания
Решение по шагам
Как рассуждать
Решение. 1.Область Условие 1 (y>=x) Условие 2 (y>=0) Условие 3 (y<=2-x*x) Программа выведет Область обрабатывается верно A да да нет не принадлежит да В да нет - - нет С нет - - - нет D нет - - - нет Е да да да принадлежит да F да нет - - нет G нет - - - нет Н нет - - - нет
Осталось ещё 1 шаг
Возможная доработка (Паскаль):if (y<=2-x*x)…
Бесплатно · займёт минуту