Ученик написал такую программу:Паскаль
Условие
Требовалось написать программу, при выполнении которой с клавиатуры считываются координаты точки на плоскости (х, у — действительные числа) и определяется принадлежность этой точки заданной закрашенной области (включая границы). Ученик написал такую программу:Паскаль | Бейсик | var x, y: real; beginreadln(x,y);if y >= xx − 6 then beginif xx + yy <= 16 then write('принадлежит')endelseif x >= 0 thenwrite('принадлежит')elsewrite('не принадлежит')end. | INPUT x, y IF y >= xx − 6 THEN IF xx + yy <= 16 THEN PRINT "принадлежит" ELSE IF x => О THEN PRINT "принадлежит" ELSE PRINT "не принадлежит" END IF END IF END | Си++ | Алгоритмический язык | #include <iostream>using namespace std;int main(){float x, y;cin >> x >> y; if (y >= xx − 6) {if (xx +yy <= 16) cout << принадлежит;}elseif (x >= 0)cout << "принадлежит";elsecout << "не принадлежит";} | алгначвещ x, y ввод x, yесли y >= xx − 6 тоесли xx + yy <= 16 товывод 'принадлежит'всеиначеесли x >= 0 товывод 'принадлежит' иначевывод 'не принадлежит'всевсекон | Python | x = float(input())y = float(input())if y >= xx − 6: if xx + y*y <= 16: print("принадлежит")else: if x => 0: print("принадлежит") else: print("не принадлежит") |

При проверке работы программа выполнялась по шагам для некоторых контрольных значений х и у, при этом был заполнен протокол тестирования. В результате неаккуратного обращения протокол был испорчен, частично сохранились только четыре строки: Область | Условие 1 (y >= xx - 6) | Условие 2 (xx + yy<= 16) | Условие 3 (x >= 0) | Вывод | Верно | | да | | | — | | | | | | принадлежит | нет | | | | | не принадлежит | да | | | | — | | да | | | | да | | да | Графы протокола содержат следующую информацию. Область - часть плоскости, которой принадлежит проверяемая точка. (Всевозможные области отмечены на рисунке буквами А, В, С, ... S.) Условие 1, Условие2, Условие 3 — результат проверки соответствующегоусловия (да или нет). Если условие не проверялось, в протокол записывалсяпрочерк. Вывод — сообщение, которое вывела программа. Если программа ничего не вывела, в протокол записывался прочерк. Верно - итоговое заключение (да или нет) о правильности результата работы программы при данных значениях х и у. Последовательно выполните следующее.1. Восстановите уцелевшие строки протокола, заполнив все клетки таблицы. Там, где содержание восстанавливается неоднозначно, запишите любое возможное значение. Например, если для нескольких областей получается одинаковая строка таблицы, укажите в графе «Область» любую из этих областей.2. Укажите, как нужно доработать программу, чтобы не было случаев её неправильной работы. (Это можно сделать несколькими способами, достаточно указать любой способ доработки исходной программы.) Критерии оценивания выполнения задания | Баллы | Выполнены все три действия: верно заполнена таблица, исправлены две ошибки. Программа для всех пар чисел х, у верно определяет принадлежность или непринадлежность точки закрашенной области. Во фрагментах программ допускается наличие отдельных синтаксических ошибок, не искажающих замысла автора решения. При написании операций сравнения допускается одно неправильное использование строгих/нестрогих неравенств (считается несущественной ошибкой, погрешностью записи). Например, вместо «у>=хх-6» используется «у>х*х − 6» | 3 | Правильно выполнены два действия из трёх: исправлены обе ошибки, но таблица отсутствует либо содержит ошибки, или же приведена верная таблица, но исправлена только одна ошибка программы. Два балла ставятся также в случае, если таблица заполнена верно, а в программе правильно записаны все условия, но логическое выражение получилось неверным из-за ошибки в учёте приоритета операций (не расставлены или неверно расставлены скобки).При оценивании этого задания на 2 балла допускается не учитывать корректность работы программ на точках границ областей (вместо нестрогих в решении были использованы строгие неравенства) | 2 | Правильно выполнено только одно действие из трёх, то есть не выполнены условия, позволяющие поставить 2 или 3 балла, и имеет место одна из следующих ситуаций1. Таблица заполнена и содержит ошибки в не более чем одной строке; ни одна из ошибок не исправлена.2. Таблица не заполнена (или заполнена и содержит ошибки более чем в одной строке); исправлена ровно одна ошибка программы. При этом допускается не учитывать корректность работы программ на точках границ областей (вместо нестрогих неравенств в решении были использованы строгие) | 1 | Не выполнены условия, позволяющие поставить 1, 2 или 3 балла | 0 | Максимальный балл | 3 |
Формат задания
Решение по шагам
Как рассуждать
Область | Условие 1 (y >= x*x -
Осталось ещё 5 шагов
Шаг 2
Шаг 3
Шаг 4
Шаг 5
Шаг 6
Бесплатно · займёт минуту