Программист торопился и написал программу неправильно. Бейсик
Условие
Требовалось написать программу, при выполнении которой с клавиатуры считывается координата точки на прямой (x — действительное число) и определяется принадлежность этой точки одному из выделенных отрезков В и D (включая границы). Программист торопился и написал программу неправильно.

Бейсик | Паскаль | INPUT x IF x>=-3 THEN IF x<=9 THEN IF x>1 THEN PRINT "не принадлежит" ELSE PRINT "принадлежит" ENDIF ENDIF ENDIF END | var x: real;beginreadln(x);if x>=-3 thenif x<=9 thenif x>1 thenwrite('не принадлежит')elsewrite('принадлежит')end. | Си++ | Алгоритмический язык | #include <iostream>using namespace std;int main(void){float x;cin >> x;if(x>=-3)if(x<=9)if(x>1)cout << "не принадлежит";elsecout << "принадлежит";} | алгначвещ xввод xесли x>=-3 тоесли x<=9 тоесли x>1 товывод 'не принадлежит'иначевывод 'принадлежит'всевсевсекон | Python | x = float(input())if x >= -3: if x <= 9: if x > 1: print("не принадлежит") else: print("принадлежит") | Последовательно выполните следующее.1. Перерисуйте и заполните таблицу, которая показывает, как работает программа при аргументах, принадлежащих различным областям (A, B, C, D и E). Границы (точки -3, 1, 5 и 9) принадлежат заштрихованным областям (B и D соответственно).В столбцах условий укажите «Да», если условие выполнится; «Нет», если условие не выполнится; «—» (прочерк), если условие не будет проверяться; «не изв.», если программа ведет себя по-разному для разных значений, принадлежащих данной области. В столбце «Программа выведет» укажите, что программа выведет на экран. Если программа ничего не выводит, напишите «—» (прочерк). Если для разных значений, принадлежащих области, будут выведены разные тексты, напишите «не изв.». В последнем столбце укажите «Да» или «Нет».2. Укажите, как нужно доработать программу, чтобы не было случаев её неправильной работы. (Это можно сделать несколькими способами, достаточно указать любой способ доработки исходной программы.) Область | Условие 1 (x >= -3) | Условие 2 (x <= 9) | Условие 3 (x > 1) | Программа выведет | Область обрабатывается верно | A | | | | | | B | | | | | | C | | | | | | D | | | | | | E | | | | | | Критерии оценивания выполнения задания | Баллы | Выполнены все три действия | 3 | Правильно выполнены два действия из трёх (исправлены обе ошибки, но в пункте 1 задания не приведена таблица (либо таблица содержит ошибки в двух и более строках), либо приведена таблица (которая содержит ошибки не более чем в одной строке), но исправлена только одна ошибка программы). При написании операций сравнения допускается одно неправильное использование строгих/нестрогих неравенств (считается несущественной ошибкой, погрешностью записи). Например, вместо «x>=5» используется «x>5» | 2 | Правильно выполнено только одно действие из трёх, т.е. либо только приведена таблица, которая содержит ошибки в не более чем одной строке, либо таблица не приведена (или приведена и содержит ошибки более чем в одной строке), но исправлена одна ошибка программы. При оценивании этого задания на 1 балл допускается не учитывать корректность работы программ на точках границ областей (вместо нестрогих неравенств в решении были использованы строгие неравенства или наоборот) | 1 | Все пункты задания выполнены неверно (таблица анализа правильности алгоритма не приведена либо содержит ошибки в двух и более строках, программа не приведена либо ни одна из двух ошибок не исправлена) | 0 | Максимальный балл | 3 |
Формат задания
Решение по шагам
Как рассуждать
Решение. Элементы ответа:1.Область | Условие 1 (x >= -3) | Условие 2 (x <=
Осталось ещё 3 шага
Шаг 2
Шаг 3
Шаг 4
Бесплатно · займёт минуту